All Servers SourceMod Updates, New Maps and entWatch

#1
Hi All,

Just a handful of updates for all of the bG servers today. The latest version of SourceMod has been uploaded to all the servers. This should help with stability. I'll be doing my usual plugin update check next weekend and I'll have another one of these updates then. For now, let me run through specifically what's changed on each server:

Zombie Escape
  • Replaced current Mako map with ze_FFVII_Mako_Reactor_v5_3_v5
  • Added map ze_ffxii_westersand_v7_2_e6
  • Adjusted zombie spawn time from 33 seconds to 36 seconds
  • Added entWatch (CSGO) to the server
Easy Surf
  • Added a "fix angles" plugin to fix Bad SetAngles command spam
Please keep an eye on these two servers. entWatch is a HUGE add to the server and it's possible it could break or crash the server if not properly configured. If you notice more crashes or maps not working as expected then please let me know. I'll be traveling this weekend, but should be able to respond to PMs here.

As for for surf, the "fix angles" plugin is a toss up. It could do something or do nothing. If you notice weird things on the server then please let me know. I'll remove the plugin.
 

Hardcore

Currently Online.. Probably.
Council Member
#2
Awesome, will keep an eye out for EntWatch hiccups!

Is EntWatch fully automatic or do we have to configure it per map/weapon?
 
#3
From what I've seen it is automated the chat plugin can get a bit cluttered on the mako version but i'm sure there is some configuration that can be done to ease it. I'll take some screenshots when servers empty and show them to bor3d
 

Fruit

Does not Expire
Council Member
#4
@bor3d The Timer for the train cars in the beginning of Mako has a timer of 30 seconds until they open. The zombie spawn timer keeps shifting from 28-31 seconds, maybe reducing 2 seconds might be a good idea since the max timer Ive seen for the spawn has been 31 seconds.

EDIT: Maybe a good idea would todo Zombie Protection for 30 seconds in the cars until they open with the default zombie timer?
 
Last edited:

Hardcore

Currently Online.. Probably.
Council Member
#5
Looks like EntWatch tries to colour code names in chat when it gives info but it just ends up looking kinda spammy/random letters in chat.
There's 5 different 6 digit hexadecimal code used (around player names, [entwatch], item name, 'used ___' text, ect. )
 
#6
Looks like EntWatch tries to colour code names in chat when it gives info but it just ends up looking kinda spammy/random letters in chat.
There's 5 different 6 digit hexadecimal code used (around player names, [entwatch], item name, 'used ___' text, ect. )
That's not fixable because CSGO doesn't let you change colors like that. I'm unsure of what can be done.
 

Hardcore

Currently Online.. Probably.
Council Member
#7
That's not fixable because CSGO doesn't let you change colors like that. I'm unsure of what can be done.
Are we able to modify the code? We could just remove the colour coding and it'd be fine.
 
#8
Are we able to modify the code? We could just remove the colour coding and it'd be fine.
What I had in mind, Would be a bit of a task because as I saw it was per map per item basis. So if there is a config file it would have to be a tedious amount of work for the 20+ maps we have with items
 
#11
I've made some changes to the server today. Please check to see if the colors are working now.
 
#12
I noticed that entWatch did not work on the mako version we run, it says it supports the map but no visual indications next to our names or in chat of item usage, is there a possibility of this being fixed, from what i saw all other maps worked correctly though.
 
#13
I noticed that entWatch did not work on the mako version we run, it says it supports the map but no visual indications next to our names or in chat of item usage, is there a possibility of this being fixed, from what i saw all other maps worked correctly though.
It's set to, if it's not working then I'm not 100% sure why.
 
#14
Do you think you can try re-downloading the config for the map maybe it's corrupted in some way
 
#15
Do you think you can try re-downloading the config for the map maybe it's corrupted in some way
It's been uploaded a number of times now. If it's still not working then I'm not sure.
 
#16
Hey guys, I replaced the mako config with a new one. Let me know how that one works :)